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1. NAS
A NAS unit is a computer connected to a network that provides only file-based data storage services
to other devices in the network. Although it may technically be possible to run other software on a
NAS unit, it is not designed to be a general purpose server. For example, NAS units usually do not
have a keyboard or display, and are controlled and configured over the network, often using a
browser.

NAS systems contain one or more hard drives, often arranged into logical, redundant storage
containers or RAID.

NAS uses file-based protocols such as

• NFS (popular on UNIX systems),

• SMB/CIFS (Server Message Block/Common Internet File System) (used with MS Windows
systems),

• AFP (used with Apple Macintosh computers), or

• NCP (used with OES and Novell NetWare).

NAS units rarely limit clients to a single protocol. (see: Wikipedia:NAS)

1.1. Providing music with NAS
General recommendations:

• On your NAS, provide all music through a folder and network share called music.

• Below music, the artist folders should be listed.

• Map this network share on your PC through a short mapping like

 net use Y: \\192.168.1.250\music

or on your Mac through a short Volume reference.

1.2. Preperation of music files

3.7. Step 7: Prepare iTunes scanning. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

3.8. Step 8: Start NAS scan . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

4. Playlist from NAS is incomplete or empty . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

4.1. Invalid music files referenced. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

4.2. Special Characters in Meta data and/or file paths . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

4.3. Complicated and unresolvable music file paths . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

4.4. Absolute file paths for optimum match . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15
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1.2.1. File Format

• supported music files

◦ MP3

◦ FLAC

◦ M4A

• supported playlist files

◦ .M3U

• supported image files (for coverart)

◦ .PNG

◦ .JPG

1.2.2. Meta Data

• Avoid empty or incomplete meta data, especially

◦ empty artist name

◦ empty album name

◦ empty track name

• When purchasing music files from the web, make sure they contain artist, album and
trackname meta data

• When importing CDs to a NAS, make sure to use software or a service that automatically writes
artist, album and trackname information into the music files, and ideally also album cover
images

You can check the meta data by tools like:

• iTunes (free software from Apple)
right click on any track, select "Get Info" and check that artist, album and track name data are
not empty

• MP3Tag (freeware)
run that tool, load any album folder on your NAS, and check that artist, album and track name
data are filled in

1.2.3. Recommended NAS folder structure

Example: If there is a NAS machine called "mynas", this is recommended:

• provide a share name "music" that exports a folder "music"

• create a folder "playlist" within "music"

• create folders of all artist names within "music"

• within these artist folders, there should be album folders and therein the actual music files

• optionally, create an iTunes database within "music"
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When entering the NAS share at trivum, it will look like

 smb://mynas/music

and all further folder paths will look like

 smb://mynas/music/playlist                   - may contain .m3u files
 smb://mynas/music/Abba                       - first artist folder
 smb://mynas/music/Abba/The Album             - first album folder
 smb://mynas/music/Abba/The Album/Eagle.mp3   - music file

1.2.4. NAS network path

• the NAS has a symbolic name within the SMB network, called machine name in the following

• within the NAS there must be another symbolic name for a folder, called the share name

• both are combined into one long name, the network path

 smb://MyLivebook/music

This means: on the machine "MyLivebook" there is a folder identified by the name "music".

1.2.5. Connecting a NAS to trivum


Always try to store at least one music file on the NAS before integrating the NAS
with trivum. This checks if the NAS is configured to supply storage space at all.

1. Find the network path of your NAS music folder.

2. Create a new Share

a. System V9/V10:

i. Open the trivum Multiroom Setup (Web configuration)

ii. Music / Music on NAS / Add network share

b. System V8:

i. Open the trivum Multiroom Setup Tool

ii. Click Database & Media → add network share

c. System V7:

i. Click Streaming → Library

3. Enter a NAS folder path. You can type it like:
\\nasaddress\sharename or smb://nasaddress/sharename.
for example:
\\192.168.1.250\music or smb://192.168.1.250/music
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4. Enter a Workgroup, Username and Password for that share if necessary. Details can be found in
the administration surface of your NAS device.

5. About shared folders of Windows computers:

a. with Windows 7 a non empty username and password is required, even if it’s just a dummy.

b. with Windows 10 a full Windows account with non empty password must be used to restrict
access to the share, and configured at trivum. Furthermore V9.36 or higher is required, for
SMB3 protocol support. In the Windows Defender Firewall, you may have to enable access
for the Registration Service ("Anmeldedienst") in the Firewall settings. If that doesn’t work
deactivate the Firewall.

6. Test access to the NAS by clicking "Refresh music index", or "Rescan all"

7. Press the Refresh button (2 or 3 arrows in a circle) repeatedly to see status updates.

◦ If you see a message "scanning files" then access works.

◦ If you see "no access" check if your NAS path and all other data are correct. Also make sure
to use "/" slashes after smb:, but not "\".


To make the connection between NAS and trivum work permanently you must
configure a fixed IP in the NAS' administration GUI.

1.2.6. Checking the playlist import process

You can check what the server does in detail during playlist import, by opening the URL
/print/scanner-trace at the server Web GUI. Look for lines like

m3u.noacc:  -  file not found under that filename
m3u.fuzz :  -  playlist entry matches by fuzzy name comparison
m3u.remap:  -  playlist entry matches by remapped path name
m3u.miss :  -  entry cannot be matched to tracks in the database

When scanning a NAS, a list of invalid music files may be produced. This means

• the music file cannot be accessed

• the music file has empty or incomplete meta data (see Preperation of music files)

• an iTunes track mismatch

• unsupported playlist file type (see File Format)

• M3U playlist mismatch

• files without cover art

• files with unreadable cover art

1.2.7. Reasons for slow scanning

Check thoroughly if your NAS contains redundant tracks, i.e. them same Artist/Album/Trackname
unit stored in multiple music files, maybe in different folders, maybe with different formats (like
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.MP3 and .FLAC). This may also cause Playlist mismatches.

1.2.8. Possible sources of error

itunes track mismatch

trivum gets a list of tracks from the iTunes database and tries to find those tracks in its own
database. This match is based on Artist name, Album name and Track name, or by the Music file
path. Possible reasons why matching fails can be:

• the iTunes database contains references to files on a different NAS, or a different path in the
NAS, or even local files on some PC or Mac not related to the NAS

• Artist, album or track name or the music file path contain special characters. trivum tries to
convert those characters, but this will not always work

• the same track is listed twice in the iTunes database, referencing two different music files.
trivum will use the first listing. Further listings are skipped

• tracks with a format which is not readable by trivum (like video files) should not be added to
the iTunes database

If an iTunes playlist misses tracks within trivum, the reasons are always mismatched tracks in the
iTunes database.

M3U playlist mismatch

trivum reads .M3U files found in the NAS and tries to match the entries within those files by Artist
name, track name, and music file path. Possible reasons why matching fails can be:

• Artist, album or track name, or the music file path contain special characters. trivum tries to
convert those characters, but this will not always work.

• Music files are stored in a complicated non-standard directory structure with too many
directories. The recommended structure on a NAS looks like:

 /music/artist name/album name/track name

with "music" being the share name exported by the NAS. If there are additional folders between
"music" and the artist name, trivum tries to match the path although, but this will not always work.

If an .M3U playlist file produces many errors: open it with a text editor and check entries for
plausibility. For example, if all entries refer to music files stored on a completely different NAS
machine or path, it cannot work.

1.2.9. files without coverart

Usually, all files of an artist+album combination contain cover art. If one or more files do not, then
the first file per album is listed here. This does not necessarily mean there is no cover art displayed
for the album; if at least one file within the album contains cover art, you can ignore further error
listings for this album.

6



1.2.10. files with unreadable cover art

Please check the listed files with a tool like Mp3tag (free software) if they contain unusually large
cover art files, or files with an image type not being .jpeg or .png.

1.3. Well known issues

1.3.1. Synology

Make sure that a "Volume" is really defined. It may happen that with a new NAS no Volume is
defined, but the NAS allows to define shares, which are however unusable because without a
volume there is no storage space.

1.4. Playing Sampler / Compilation CDs from NAS
Music Albums containing tracks of many different artists are called compilations. When importing
these into the trivum MusicCenter system from a NAS, it must be prepared that all music files of
your compilation albums are marked as compilations, i.e. have the COMPILATION flag set in their
meta fields. The trivum MusicCenter will then recognize .MP3, .M4A and Flac files marked as
compilation, and offers tracks of those albums correctly grouped on the visualization.

1.4.1. How to check if your tracks have the COMPILATION flag set

1. Run the tool Mp3Tag

2. Select a compilation folder of your NAS

3. Click one of the listed music tracks

4. Select View → Extended Tags

5. Search for a field COMPILATION
→ If the field is not shown, the flag is not set

At least for MP3 files this can also be done with iTunes. In iTunes, select track details and look for
the Compilation check box.

1.4.2. How to set the COMPILATION flag on many files

It is recommended that you organize your NAS folders in a way that all compilation album folders
are placed within a big root folder called Compilations.

1. Run the tool Mp3Tag

2. Select that root folder with all your compilations in it.

3. Select ALL tracks by pressing CONTROL+A

4. Select View → Extended Tags
→ If COMPILATION is not shown anywhere

a. Select Add field (star symbol)
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b. Select the field COMPILATION

c. Type 1 as value

5. Save all tracks

1.5. Resetting the music database and all cover art
This can be helpful in some rare cases, for example if cover art does not appear in the player screen
after a software update although a normal rescan was selected.

1.5.1. System V9/V10

Click Music / Music on NAS / Advanced Options / Clear database

1.5.2. System V8

Click Database & Media → Database → Reset

1.5.3. System V7

Click Streaming → Coverart → Delete coverart cache

After the database reset, click Rescan all.
→ The whole NAS content will be re-read in complete, which will take much longer than a normal
rescan.

2. Step by Step: create a music database on
NAS with iTunes
These is a Step-by-Step instruction guide about creating an iTunes database directly on a NAS that
trivum can read to synchronize playlists.

Preconditions:

• a NAS (in this example called "mynas")

• some music files on the NAS available from smb://mynas/music

• iTunes

• a trivum device

• working network

2.1. Step 1: Create a iTunes Database
Create a new iTunes Database within the music folder on the NAS

1. Make sure iTunes is not running

2. Windows: Hold SHIFT and (double) click on the iTunes icon
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3. Mac: keep ALT pressed and click on the iTunes icon
→ You should see a popup "Select iTunes Database"

4. Select: Create new database

5. As target folder, select the NAS music folder

→ iTunes will create a database folder within /music, containing some files, the most important
being iTunes Library.xml

If you cannot find the .xml file on the NAS, but instead an .itl file, check this option within iTunes:
Preferences / Advanced / Share iTunes Library XML with other applications

2.1.1. Changes with Mac OS since 2019

• There is no iTunes any longer, but the Music.app.

• This app no longer writes an .xml file automatically, but you can export it manually by the step:

File / Library / Export Library

So whenever iTunes is referenced in the following, this also means the Music.app, with manual
.xml export.

2.2. Step 2: Fill your iTunes database
Import the music files from the NAS music folder into the iTunes database.

In iTunes:

1. Click File → Add folder to database

2. Select your NAS music folder

→ All music files from within smb://mynas/music are now referenced by the iTunes database

2.3. Step 3: Playlists
Create some playlists in iTunes

2.4. Step 4: Configure trivum
Enter network path in trivum:

1. Open the Multiroom Setup

2. Click Music / Music on NAS / add network share

3. Enter your Network share URL

 smb://mynas/music
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Enable use of an iTunes Database file:

• with software V9/10: Music / Music on NAS / Advanced options / Use iTunes DB playlists

• with software V8: Database / iTunes database file / settings / use iTunes DB playlists

2.5. Step 5: Start NAS scan
Start scanning:

In the trivum Multiroom Setup:

• Select Music / Music on NAS / Refresh musicindex

• right near the network share path, it should show: "The network share was readable"

• there should be status updates at the bottom

• after the scan has completed, there should be an info line telling about the found iTunes
Library.xml file.

If something is missing, check the structure and content of your C:\Music folder. It should look
similar to:

EXAMPLE FOLDER STRUCTURE FOR NETWORK SHARES
   Music\iTunes 1\iTunes Library Extras.itdb
   Music\iTunes 1\iTunes Library Genius.itdb
   Music\iTunes 1\iTunes Library.itl
   Music\iTunes 1\iTunes Library.xml
   Music\u2\POP\Discotheque.mp3
   Music\u2\POP\Do you feel loved.mp3
   Music\u2\POP\Gone.mp3
   Music\sade\The Best Of Sade\Cherish The Day.mp3
   Music\sade\The Best Of Sade\Hang On To Your Love.mp3
   Music\sade\The Best Of Sade\Is It A Crime.mp3

This means:

• there should be artist folders (e. g. u2 and sade)

• within those folders, there should be album folders

• within those, there should be music files

• there must be an iTunes database home folder iTunes 1

• there must be an iTunes database .xml file iTunes 1\iTunes Library.xml
This file contains playlist information and is scanned by trivum for changes

After scanning the whole music folder trivum should also find the iTunes database and import
playlists automatically.

Furthermore, trivum will check every 15 seconds if the iTunes database file was changed, so
changes in playlists should ideally be updated within half a minute.
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3. Step by Step - Provide music from PC with
iTunes
This is a Step-by-Step instruction guide about creating and sharing an iTunes database on a PC for
your trivum device.

Preconditions:

• a Windows PC with iTunes installed

• some music files

• a trivum device

• working network

3.1. Step 1: Your Music Folder
Create a Music folder on your PC, for example C:\Music

3.2. Step 2: Create a iTunes Database
Create a new iTunes Database within this music folder:

1. Make sure iTunes is not running

2. Hold SHIFT and (double) click on the iTunes Icon
→ You should see a popup Select iTunes Database

3. Select Create new database

4. Select your target folder (the music folder, which you created in step 1)

→ the iTunes Database will be created within this folder

3.3. Step 3: Fill your music folder
Copy your music files into the music folder you created.

• Make sure to store your music in a folder structure like artist / album / trackname

 ZZ Top/Afterburner/Planet of Woman.mp3

• Make sure that you use only supported audio files (.MP3, .M4A or .FLAC) audio files

3.4. Step 4: Fill your iTunes database
Import the music files from your music folder into the iTunes database.

In iTunes:
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1. Click File → Add folder to database

2. Select your music folder.

→ All music files from you music folder are now referenced by the iTunes database

3.5. Step 5: Network access
Make your music folder accessible in your network:

In Windows explorer:

1. Right-Click on your music folder

2. Make it available in the network, under a share name like "Music"

3.6. Step 6: Configure trivum
Enter network path in trivum:

• Open the Multiroom Setup

• Click Music / Music on NAS / add network share

• Enter your Network share URL.
Example: IP for your PC is 192.168.1.89

 smb://192.168.1.89/Music

• Enter Workgroup, User and Password

About username and password:

• Windows 7 requires that you connect with some username and password, even if the network
share does not need it. So at least enter this data:

Workgroup: (leave empty)
User: user
Password: pass

The text "user" and "pass" are dummies but required to allow a successful Windows share
connection. If your share is protected by another user/pw, then enter that instead.

• with Windows 10 a full Windows account with non empty password must be used to restrict
access to the share. Then enter these data at trivum. Furthermore V9.36 or higher is required,
for SMB3 protocol support. In the Windows Defender Firewall, you may have to enable access
for the Registration Service ("Anmeldedienst") in the Firewall settings. If that doesn’t work
deactivate the Firewall.
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3.7. Step 7: Prepare iTunes scanning
Enable automatic iTunes Database scanning.

• Open the Multiroom Setup

• Select: Music / Music on NAS / Advanced options

• Activate: Use iTunes DB playlists

3.8. Step 8: Start NAS scan
In the Multiroom Setup: * Click: Music / Music on NAS / Refresh music index * right near the
network share path, it should show: was readable * there should be status updates at the bottom *
after the scan has completed, right near iTunes database file there should be infos

If something is missing, check the structure and content of your music folder.

It should look similar to:

EXAMPLE FOLDER STRUCTURE FOR NETWORK SHARES
   Music\iTunes 1\iTunes Library Extras.itdb
   Music\iTunes 1\iTunes Library Genius.itdb
   Music\iTunes 1\iTunes Library.itl
   Music\iTunes 1\iTunes Library.xml
   Music\u2\POP\Discotheque.mp3
   Music\u2\POP\Do you feel loved.mp3
   Music\u2\POP\Gone.mp3
   Music\sade\The Best Of Sade\Cherish The Day.mp3
   Music\sade\The Best Of Sade\Hang On To Your Love.mp3
   Music\sade\The Best Of Sade\Is It A Crime.mp3

This means:

• there should be artist folders (e. g. u2 and sade)

• within those folders, there should be album folders

• within those, there should be music files

• there must be an iTunes database folder iTunes 1

• there must be an iTunes database .xml file iTunes 1\iTunes Library.xml.
this file contains playlist informations and is scanned by trivum for changes.

4. Playlist from NAS is incomplete or empty

4.1. Invalid music files referenced
Make sure that all music files in your playlist have non-empty Artist, Album and Track name fields.
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If one of these fields is empty, the music file is not added to the trivum database, and therefore it
will not show up in your playlist.

Check if the music files contain information about artist, album and track name.

In iTunes for example, right-click a track and select Get Info.

4.2. Special Characters in Meta data and/or file paths
Artist, album, trackname, and/or the path and filename of music tracks contained in the playlist
shouldn’t contain any special characters like Umlauts, Accents, or event Chinese characters. This
might cause problems for the trivum MusicCenter to match those playlist entries to tracks which
are already in the database.

Technical background:

iTunes for Macintosh saves special characters in an untypical non-standard format. The trivum
MusicCenter tries to compensate by fuzzy matching, but this doesn’t always work, especially not
with Asian characters. Therefore try to change or remove special characters from tracks listed in
Playlists like:

• change "ä" to "a"

• change "ó" to "o"

• remove Chinese characters

Also check the directory and file name on the NAS, and change characters there as well. Then re-
import the tracks into iTunes, re-export the playlists to the NAS, and re-import into trivum.

4.3. Complicated and unresolvable music file paths
Check carefully how you import the NAS content to your PC or Notebook. Make sure to use short
and simple path names for all your network shares. Look into the exported .M3U playlist files and
check if the music files have a simple, straightforward path.

Bad example:

 #EXTM3U
 #EXTINF:513,Planet of Women - ZZ Top
 Y:\imported CD\Music\Music\ZZ Top\Afterburner\01 Planet of Women.m4a
 #EXTINF:489,Lovely Day - Billie Holiday
 Y:\imported CD\Music\Music\Billie Holiday\Greatest Hits\Lovely Day.m4a

The playlist file references music files with very complicated paths stored under Y:\imported
CD\Music\Music. the trivum server won’t get any information about Y:\imported CD\Music\Music
because it has no access to details of the PC or Notebook, and how NAS shares are mapped therein.
Therefore it cannot map the file path, and has to use artist and track name to resolve entries, which
is highly unreliable.
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Good example:

 #EXTM3U
 #EXTINF:513,Planet of Women - ZZ Top
 Y:\Music\ZZ Top\Afterburner\01 Planet of Women.m4a
 #EXTINF:489,Lovely Day - Billie Holiday
 Y:\Music\Billie Holiday\Greatest Hits\Lovely Day.m4a

The playlist file references music files with very simple paths stored under Y:\Music. the trivum
server is able to ignore a short (single component) part like Y:\Music, and to match music files by
the rest of path, e. g. ZZ Top\Afterburner... especially if the network share name from NAS is also
just music.

4.4. Absolute file paths for optimum match
If you create playlist files containing full absolute SMB path names, using UNIX Forward Slashes "/"
(not Windows Back Slashes "\") like in

 #EXTINF:232,La Grange - ZZ TOP
 smb://RackStation/T-Drive/Musik/trivumDemo/ZZ Top/Greatest Hits/La Grange.mp3
 #EXTINF:239,Gimme All Your Lovin' - ZZ TOP
 smb://RackStation/T-Drive/Musik/trivumDemo/ZZ Top/Greatest Hits/Gimme All Your
Lovin'.mp3
 #EXTINF:254,Sharp Dressed Man - ZZ TOP
 smb://RackStation/T-Drive/Musik/trivumDemo/ZZ Top/Greatest Hits/Sharp Dressed Man.mp3
 #EXTINF:123,The ue=Ã¼ track - trivum
 smb://RackStation/T-Drive/Musik/trivumDemo/UmlautPfade/the ae=Ã¤ and oe=Ã¶ album/The
ue=Ã¼ track.mp3

then chances for a full data match are best. Special characters should then be encoded as UTF-8 as
seen in the last track above.

You may also check what the server does in detail during playlist import, by opening the URL

 /print/scanner-trace

Then look for lines like: * m3u.noacc: - file not found under that filename * m3u.fuzz : - playlist
entry matches by fuzzy name comparison * m3u.remap: - playlist entry matches by remapped path
name * m3u.miss : - entry cannnot be matched to tracks in the database
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